Overview

Section Designer is a powerful utility that allows design of simple and complex cross sections. The following procedure is intended to introduce the various menu commands available to make generating a cross section and reviewing interaction surface and moment curvature plots quick and easy.

Note:  Within the analysis and design program (e.g., SAP2000, ETABS), use the Define menu > Materials command to define the material properties and use the Define menu > Section Properties > Reinforcement Bar Sizes command to specify rebar to be used in the cross section before beginning the following process.

  1. Use the Define menu > Fiber Layout command to define the fiber model. The fiber model  can be used to calculate moment-curvature curves and PMM interaction surfaces as well as fiber hinges.

  2. Use one of the commands on the Draw menu to draw a shape and begin generating the cross section (Draw Structural Shapes, Draw Solid Shapes, Draw Poly Shape, Draw Caltrans Shape).

  3. Click the Display menu > Show Fibers command to view a graphical representation of the fiber model as well as a form that provides the data for each fiber generated for the fiber model, including the area, coordinates, and material properties.

  4. Refine the geometry for the cross section. Right click on the shape drawn in Step 2 to display the Shape Properties form for the type of shape. That form has various options to specify the geometry of the shape. After the shape has been drawn, the Reshape Mode can be used to revise the geometry. Use the Assign Display Colors form to specify the display colors for the components of the cross section, both for on-screen display and for output to a printer.

Note:  With the Shape Properties form displayed, click the F1 key to display a Help topic specific to the form for that particular type of shape.

TIP:  The Shape Properties form may include a Materials drop-down list, depending on the type of shape. The list will consist of the materials properties as defined in the analysis and design program within which Section Designer is accessed (e.g., SAP2000, ETABS). As noted above, make modifications to the material properties if necessary in the analysis and design program before accessing Section Designer.

Cross sections can be generated by combining individual shapes using commands on the Edit menu.

  1. Use the Edit menu > Replicate command to quickly add duplicate shapes to the cross section.

  2. Use the Edit menu > Align subcommands to align two or more shapes. Use the Nudge feature to move shapes in specified increments.

  3. The Edit menu > Change Shape to Poly command can be used to change a structural or solid shape to a poly shape. The geometry of structural and solid shapes is defined by specified height and width items. The geometry of poly shapes is defined by the coordinates of the corner points of the poly shape. Converting a structural or solid shape to a poly shape allows the geometry of the shape to be tweaked in ways that otherwise would not be possible.

  4. Use the Edit menu > Check Section for Overlaps command to check the section for poly areas that overlap. If areas overlap, the top section controls. Click on one of the overlapping shapes to select it and use the Edit menu > Move Forward or Edit Menu > Move Backward command to change which shape is on top, as needed.

  5. Use the  Edit menu > Merge Two Polys command to merge two shapes that overlap.

  6. Use the Edit menu > Get Two Poly Intersections command to limit the resulting shape to the area of overlap for two selected shapes.

  7. Use the Edit menu > Get Two Polys Differences command to eliminate the area of overlap for two selected shapes.

  8. Use the Edit menu > Remove Bottom Polys overlapping area command to eliminate the areas of overlap for two selected shapes that have different material properties.

Note:  The Edit menu > Undo and Redo commands and toolbar buttons,  , will reverse the immediately previous action back to the last time the file was stored.

  1. Define the rebar. Depending on the type of shape, the Shape Properties form has an option to specify that reinforcing be included in the shape. The Draw menu > Draw Reinforcing Shapes subcommands can also be used to add rebar to a shape.

By default, the program provides single rebar elements at each corner of a reinforced shape and rebar line patterns along each face of  a reinforced shape. Note the following about rebar elements:

  1. Edit the rebar. For Structural Shapes, Solid Shapes, Poly Shapes, and Reinforcing Shapes defined by corner points and with a concrete material type, the Edge Reinforcing form can be used to modify the edge rebar size, maximum spacing and clear cover. Changes made on the Edge Reinforcing form apply to all of the bars along an edge. The Corner Point Reinforcing form can be used to change the size of corner rebar only.

  2. View the section stresses using the Display menu > Show Stresses command.

  3. View the section properties using the Display menu > Show Section Properties command.

  4. View an interaction diagram using the Display menu > Show Interaction Surface command.

  5. View a moment-curvature plot using the Display menu > Show Moment-Curvature Curve command.

  6. Print the currently displayed cross section using the File menu > Print Graphics command. Use the File menu > Print Setup command to specify the page layout for the print.