Design Input and Output

CSI has prepared manuals specific to the types of design available using ETABS, including

The design manuals are available as part of the ETABS installation.

Overview

The program creates design output in different formats: graphical display, tabular output, and member specific detailed design information. All graphical output can be printed. The tabular output can be saved in a file or printed. The tabular output includes most of the information that can be displayed and is generated for added convenience to the designer.

The graphical displays can be viewed in 2D or 3D mode. Use the various toolbar buttons (e.g., Set Default 3D View, Set X-Y View) to adjust the view, or use the View menu > Set Plan View or View menu > Set 3D View commands to refine the display.

The graphical display in the active window can be printed by clicking the File menu > Print Graphics command, the Print Graphics button on the toolbar, or the Ctrl+G keyboard shortcut. The display also can be captured as a bit map file (.bmp) using one of the subcommands on the File menu > Capture Picture command. The captured picture file can then be used in popular graphics programs, including Paint and PowerPoint. Alternatively, the standard Windows screen capture command (press the Print Screen button on the keyboard) can be used to create a screen capture of the entire window, or use the Alt+Print Screen command to capture only the "top layer," such as a form displayed from within the program.

By default, graphics are displayed and printed in color, assuming a color printer is available. Use the Options menu > Graphics Colors > Output command to change default colors, as necessary, including changing the background color from the default black to white. A white background can be useful when printing design output to save toner. The graphical output also can be produced in gray-scaled screen display.

The tabular design output includes input and output design information that depends on the design codes chosen when the model was first created or that were applied using the Preferences.

Please refer to the hyperlinked topics above for more information about the data available when interactive design is enabled. As an explanatory example of the advantages of interactive design, the following describes Concrete Frame Design:

After completing an analysis and design run and click the Design menu > Concrete Frame Design > Interactive Design command,  right click on a concrete frame member to enter the interactive design mode and access the Concrete Column Design Information form if a column member was right clicked or the Concrete Beam Design Information form if a beam member was right clicked. These forms may have Overwrites buttons that accesses the design type and code specific Overwrites forms. The forms can be used to change the design sections, element type, live load reduction factor for reducible live load, and many other design factors. See the appropriate form within the program for a brief description of the overwrite items. When changes to the design parameters are made using the Overwrites form, the Concrete Beam or Column Design Information forms update immediately to reflect the changes. Then other buttons on the Concrete Beam or Column Design Information forms can be used to display additional forms showing the details of the updated design. See the Member Specific Information section of this topic for more information.

In this way, the user can change the overwrites any number of times to produce a satisfactory design. After an acceptable design has been produced by changing the section or other design parameters, click the OK button on the Concrete Beam or Column Design Information form to permanently change the design sections and other overwrites for that member. However, if the Cancel button is used, all changes made to the design parameters using the Concrete Frame Design Overwrites form are temporary and do not affect the design.

As a continuation of the preceding description of interactive design, the following description relates member specific information for concrete frame members:

The longitudinal and shear reinforcing area are reported in their current units, which are displayed in the drop-down list in the lower right corner of the program window. Typically, the longitudinal reinforcing area is reported in in2, mm2, cm2 and so on. Shear reinforcing areas typically are reported in in2/in, mm2/mm, cm2/cm and so on.

The load combination is reported by its name, while station data is reported by its location as measured from the I-end of the column. The number of line items reported is equal to the number of design combinations multiplied by the number of stations. One line item will be highlighted when the form first displays. This line item will have the largest required longitudinal reinforcing, unless any design overstress or error occurs for any of the items. In that case, the last item among the overstressed items or items with errors will be highlighted. In essence, the program highlights the critical design item.

If a column has been selected and the column has been specified to be checked by the program, the form includes the same information as that displayed for a designed column, except that the data for a checked column includes the capacity ratio rather than the total longitudinal reinforcing area. Similar to the design data, the line item with the largest capacity ratio is highlighted when the form first displays, unless an item has an error or overstress, in which case, that item will be highlighted. In essence, the program highlights the critical check item.

The program can be used to check and to design rebar in a column member. When the users specifies that the program is to check the rebar in the column, the program checks the rebar as it is specified. When the user specifies that the program design the rebar configuration, the program starts with the data specified for rebar and then increases or decreases the rebar in proportion to the relative areas of rebar at the different locations of rebar in the column.

Error Messages and Warnings

Error messages and warnings may be displayed in design output. The messages are numbered and assumed to be self-explanatory.

Code Specific Parameters

Explanations of code specific parameters are available on the design-specific preferences and overwrites forms. Clicking on a preference or overwrite item in the relevant form will display a brief description of that item on the right-hand side of the Preference or Overwrite form. Depending on the parameter, further information may be available in the code-specific design manuals along with the algorithms used by the program to apply the code specific input.