cFrameObj SetReleases Method CSi API ETABS 2015
Makes end release and partial fixity assignments to frame objects.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int SetReleases(
	string Name,
	ref bool[] II,
	ref bool[] JJ,
	ref double[] StartValue,
	ref double[] EndValue,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: OnlineSystem String
The name of an existing frame object or group, depending on the value of the ItemType item.
II
Type:  OnlineSystem Boolean  
JJ
Type:  OnlineSystem Boolean  
These is an array of six booleans indicating the J-End releases for the frame object.
  • ii(0) and jj(0) = U1 release
  • ii(1) and jj(1) = U2 release
  • ii(2) and jj(2) = U3 release
  • ii(3) and jj(3) = R1 release
  • ii(4) and jj(4) = R2 release
  • ii(5) and jj(5) = R3 release
StartValue
Type:  OnlineSystem Double  
These is an array of six values indicating the I-End partial fixity springs for the frame object.
  • StartValue(0) and EndValue(0) = U1 partial fixity [F/L]
  • StartValue(1) and EndValue(1) = U2 partial fixity [F/L]
  • StartValue(2) and EndValue(2) = U3 partial fixity [F/L]
  • StartValue(3) and EndValue(3) = R1 partial fixity [FL/rad]
  • StartValue(4) and EndValue(4) = R2 partial fixity [FL/rad]
  • StartValue(5) and EndValue(5) = R3 partial fixity [FL/rad]
EndValue
Type:  OnlineSystem Double  
These is an array of six values indicating the J-End partial fixity springs for the frame object.
  • StartValue(0) and EndValue(0) = U1 partial fixity [F/L]
  • StartValue(1) and EndValue(1) = U2 partial fixity [F/L]
  • StartValue(2) and EndValue(2) = U3 partial fixity [F/L]
  • StartValue(3) and EndValue(3) = R1 partial fixity [FL/rad]
  • StartValue(4) and EndValue(4) = R2 partial fixity [FL/rad]
  • StartValue(5) and EndValue(5) = R3 partial fixity [FL/rad]
ItemType (Optional)
Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If this item is Objects, the assignment is made to the frame object specified by the Name item.

If this item is Group, the assignment is made to all frame objects in the group specified by the Name item.

If this item is SelectedObjects, the assignment is made to all selected frame objects and the Name item is ignored.

Return Value

Returns zero if the assignments are successfully retrieved, otherwise it returns a nonzero value.
Remarks

Partial fixity assignments are made to degrees of freedom that have been released only.

Some release assignments would cause instability in the model. An error is returned if this type of assignment is made. Unstable release assignments include the following:

  • U1 released at both ends
  • U2 released at both ends
  • U3 released at both ends
  • R1 released at both ends
  • R2 released at both ends and U3 at either end
  • R3 released at both ends and U2 at either end

Examples

See Also