cAnalysisResults AreaStressShell Method CSi API ETABS 2015

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int AreaStressShell(
	string Name,
	eItemTypeElm ItemTypeElm,
	ref int NumberResults,
	ref string[] Obj,
	ref string[] Elm,
	ref string[] PointElm,
	ref string[] LoadCase,
	ref string[] StepType,
	ref double[] StepNum,
	ref double[] S11Top,
	ref double[] S22Top,
	ref double[] S12Top,
	ref double[] SMaxTop,
	ref double[] SMinTop,
	ref double[] SAngleTop,
	ref double[] SVMTop,
	ref double[] S11Bot,
	ref double[] S22Bot,
	ref double[] S12Bot,
	ref double[] SMaxBot,
	ref double[] SMinBot,
	ref double[] SAngleBot,
	ref double[] SVMBot,
	ref double[] S13Avg,
	ref double[] S23Avg,
	ref double[] SMaxAvg,
	ref double[] SAngleAvg
)

Parameters

Name
Type: OnlineSystem String
ItemTypeElm
Type: ETABS2015 eItemTypeElm
NumberResults
Type: OnlineSystem Int32 
Obj
Type:  OnlineSystem String  
Elm
Type:  OnlineSystem String  
PointElm
Type:  OnlineSystem String  
LoadCase
Type:  OnlineSystem String  
StepType
Type:  OnlineSystem String  
StepNum
Type:  OnlineSystem Double  
S11Top
Type:  OnlineSystem Double  
S22Top
Type:  OnlineSystem Double  
S12Top
Type:  OnlineSystem Double  
SMaxTop
Type:  OnlineSystem Double  
SMinTop
Type:  OnlineSystem Double  
SAngleTop
Type:  OnlineSystem Double  
SVMTop
Type:  OnlineSystem Double  
S11Bot
Type:  OnlineSystem Double  
S22Bot
Type:  OnlineSystem Double  
S12Bot
Type:  OnlineSystem Double  
SMaxBot
Type:  OnlineSystem Double  
SMinBot
Type:  OnlineSystem Double  
SAngleBot
Type:  OnlineSystem Double  
SVMBot
Type:  OnlineSystem Double  
S13Avg
Type:  OnlineSystem Double  
S23Avg
Type:  OnlineSystem Double  
SMaxAvg
Type:  OnlineSystem Double  
SAngleAvg
Type:  OnlineSystem Double  
See Also