cGridSys GetGridSys_2 Method CSi API ETABS 2015
Retrieves the grid system specified by the Name item.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetGridSys_2(
	string Name,
	ref double Xo,
	ref double Yo,
	ref double RZ,
	ref string GridSysType,
	ref int NumXLines,
	ref int NumYLines,
	ref string[] GridLineIDX,
	ref string[] GridLineIDY,
	ref double[] OrdinateX,
	ref double[] OrdinateY,
	ref bool[] VisibleX,
	ref bool[] VisibleY,
	ref string[] BubbleLocX,
	ref string[] BubbleLocY
)

Parameters

Name
Type: OnlineSystem String
The name of an existing grid system.
Xo
Type: OnlineSystem Double 
The global X grid of the origin of the grid system. [L]
Yo
Type: OnlineSystem Double 
The global Y grid of the origin of the grid system. [L]
RZ
Type: OnlineSystem Double 
The rotation of an axis of the new grid system relative to the global grid system is defined as follows: (1) Rotate the grid system about the positive global Z-axis as defined by the RZ item. [deg]
GridSysType
Type: OnlineSystem String 
NumXLines
Type: OnlineSystem Int32 
NumYLines
Type: OnlineSystem Int32 
GridLineIDX
Type:  OnlineSystem String  
GridLineIDY
Type:  OnlineSystem String  
OrdinateX
Type:  OnlineSystem Double  
OrdinateY
Type:  OnlineSystem Double  
VisibleX
Type:  OnlineSystem Boolean  
VisibleY
Type:  OnlineSystem Boolean  
BubbleLocX
Type:  OnlineSystem String  
BubbleLocY
Type:  OnlineSystem String  

Return Value

Returns zero if the grid system data is successfully retrieved, otherwise it returns a nonzero value.
Remarks

Examples

See Also