cDesignSteel GetCode Method CSi API ETABS 2015
Retrieves the steel design code.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetCode(
	ref string CodeName
)

Parameters

CodeName
Type: OnlineSystem String 
This is one of the following steel design code names.
  • AISC 360-10/IBC 2012
  • AISC 360-05/IBC 2006
  • AISC ASD 01
  • AISC ASD 89
  • AISC LRFD 99
  • AISC LRFD 93
  • AS 4100-1998
  • BS 5950-2000
  • BS 5950-1990
  • CAN/CSA S16-01
  • Chinese 2010
  • CISC 95
  • CSA S16-09
  • Eurocode 3-2005
  • Eurocode 3-1993
  • Indian IS:800-2007
  • Indian IS:800-1998
  • Italian UNI 10011
  • NZS 3404-1997
  • UBC ASD 97
  • UBC LRFD 97

Return Value

Returns zero if the code is successfully retrieved; otherwise it returns a nonzero value
Remarks

Examples

See Also