Retrieves the initial condition assumed for the specified load case.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int GetInitialCase(
string Name,
ref string InitialCase
)
Function GetInitialCase ( _
Name As String, _
ByRef InitialCase As String _
) As Integer
int GetInitialCase(
String^ Name,
String^% InitialCase
)
Parameters
- Name
- Type:
System String
The name of an existing static linear load case.
- InitialCase
- Type:
System String
This is blank, None, or the name of an existing analysis case.
This item specifies if the load case starts from zero initial conditions,
that is, an unstressed state, or if it starts using the stiffness that
occurs at the end of a nonlinear static or
nonlinear direct integration time history load case.
If the specified initial case is a nonlinear static or
nonlinear direct integration time history load case,
the stiffness at the end of that case is used.
If the initial case is anything else, zero initial conditions are assumed.
Return Value
Returns zero if the initial condition is successfully retrieved;
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim InitialCase As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.LoadCases.StaticLinear.GetInitialCase("DEAD", InitialCase)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim InitialCase As String
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
'get initial condition
ret = SapModel.LoadCases.StaticLinear.GetInitialCase("DEAD", InitialCase)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub