Deletes the uniform load assignments to the specified area objects
for the specified load pattern.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int DeleteLoadUniform(
string Name,
string LoadPat,
eItemType ItemType = eItemType.Objects
)
Function DeleteLoadUniform ( _
Name As String, _
LoadPat As String, _
Optional ItemType As eItemType = eItemType.Objects _
) As Integer
int DeleteLoadUniform(
String^ Name,
String^ LoadPat,
eItemType ItemType = eItemType::Objects
)
Parameters
- Name
- Type:
System String
The name of an existing area object or group, depending on the value
of the ItemType item.
- LoadPat
- Type:
System String
The name of a defined load pattern.
- ItemType (Optional)
- Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the load assignments are deleted for
the area object specified by the Name item.
If this item is Group, the load assignments are deleted for
all area objects in the group specified by the Name item.
If this item is SelectedObjects, the load assignments are deleted for
all selected area objects, and the Name item is ignored.
Return Value
Returns zero if the load assignments are successfully deleted,
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.AreaObj.SetLoadUniform("ALL", "DEAD", -0.01, 2, False, "Local", ETABS2013.eItemType.Group)
ret = SapModel.AreaObj.DeleteLoadUniform("3", "DEAD")
ret = SapModel.View.RefreshView(0, False)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
'assign area object uniform loads
ret = SapModel.AreaObj.SetLoadUniform("ALL", "DEAD", -0.01, 2, False, "Local", ETABS2013.eItemType.Group)
'delete area object uniform load
ret = SapModel.AreaObj.DeleteLoadUniform("3", "DEAD")
'refresh view
ret = SapModel.View.RefreshView(0, False)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub