Retrieves the frame section property assigned to a frame object.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int GetSection(
string Name,
ref string PropName,
ref string SAuto
)
Function GetSection ( _
Name As String, _
ByRef PropName As String, _
ByRef SAuto As String _
) As Integer
int GetSection(
String^ Name,
String^% PropName,
String^% SAuto
)
Parameters
- Name
- Type:
System String
The name of a defined frame object.
- PropName
- Type:
System String
If no auto select list is assigned to the frame object,
this is the name of the frame section property assigned
to the frame object. If an auto select list is assigned
to the frame object, this is the name of the frame section
property, within the auto select list, which is currently
being used as the analysis property for the frame object.
If this item is None, no frame section property is assigned
to the frame object.
- SAuto
- Type:
System String
This is the name of the auto select list assigned
to the frame object, if any. If this item is returned
as a blank string, no auto select list is assigned
to the frame object.
Return Value
Returns zero if the frame object property is successfully retrieved,
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim PropName As String
Dim SAuto As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.FrameObj.GetSection("3", PropName, SAuto)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim PropName As String
Dim SAuto As String
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
'get frame section property
ret = SapModel.FrameObj.GetSection("3", PropName, SAuto)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub