cLinkObj SetGUID Method CSi API ETABS 2015
Sets the GUID for the specified link object. If the GUID is passed in as a blank string, the program automatically creates a GUID for the object.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int SetGUID(
	string Name,
	string GUID = ""
)

Parameters

Name
Type: OnlineSystem String
The name of an existing link object.
GUID (Optional)
Type: OnlineSystem String
The GUID (Global Unique ID) for the specified link object.

Return Value

Returns zero if the link object GUID is successfully set; otherwise it returns nonzero.
Remarks

Examples

See Also