Retrieves tendon property definition data.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int GetProp(
string Name,
ref string MatProp,
ref int ModelingOption,
ref double Area,
ref int Color,
ref string Notes,
ref string GUID
)
Function GetProp ( _
Name As String, _
ByRef MatProp As String, _
ByRef ModelingOption As Integer, _
ByRef Area As Double, _
ByRef Color As Integer, _
ByRef Notes As String, _
ByRef GUID As String _
) As Integer
int GetProp(
String^ Name,
String^% MatProp,
int% ModelingOption,
double% Area,
int% Color,
String^% Notes,
String^% GUID
)
Parameters
- Name
- Type:
System String
The name of an existing tendon property.
- MatProp
- Type:
System String
The name of the material property assigned to the tendon property.
- ModelingOption
- Type:
System Int32
This is either 1 or 2, indicating the tendon modeling option.
Value | Modeling Option |
---|
1 | Model tendon as loads |
2 | Model tendon as elements |
- Area
- Type:
System Double
The cross-sectional area of the tendon. [L2]
- Color
- Type:
System Int32
- Notes
- Type:
System String
- GUID
- Type:
System String
The GUID (global unique identifier), if any, assigned to the property.
Return Value
Returns zero if the property is successfully retrieved; otherwise it returns a nonzero value.
Modeling tendons as elements (
ModelingOption = 2) is not supported in ETABS.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name As String
Dim MatProp As String
Dim ModelingOption As Integer
Dim Area As Double
Dim Color As Integer
Dim Notes As String
Dim GUID As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropMaterial.AddQuick(Name, ETABS2013.eMatType.Tendon, , , , , , ETABS2013.eMatTypeTendon.ASTM_A416Gr270)
ret = SapModel.PropTendon.SetProp("T1", Name, 1, 2.25)
ret = SapModel.PropTendon.GetProp("T1", MatProp, ModelingOption, Area, Color, Notes, GUID)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name As String
Dim MatProp As String
Dim ModelingOption As Integer
Dim Area As Double
Dim Color As Integer
Dim Notes As String
Dim GUID As String
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
'add tendon material
ret = SapModel.PropMaterial.AddQuick(Name, ETABS2013.eMatType.Tendon, , , , , , ETABS2013.eMatTypeTendon.ASTM_A416Gr270)
'set new tendon property
ret = SapModel.PropTendon.SetProp("T1", Name, 1, 2.25)
'get tendon property data
ret = SapModel.PropTendon.GetProp("T1", MatProp, ModelingOption, Area, Color, Notes, GUID)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub