cAreaObj GetAllAreas Method CSi API ETABS 2015
Retrieves select data for all area objects in the model

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetAllAreas(
	ref int NumberNames,
	ref string[] MyName,
	ref eAreaDesignOrientation[] DesignOrientation,
	ref int NumberBoundaryPts,
	ref int[] PointDelimiter,
	ref string[] PointNames,
	ref double[] PointX,
	ref double[] PointY,
	ref double[] PointZ
)

Parameters

NumberNames
Type: OnlineSystem Int32 
MyName
Type:  OnlineSystem String  
DesignOrientation
Type:  ETABS2015 eAreaDesignOrientation  
NumberBoundaryPts
Type: OnlineSystem Int32 
PointDelimiter
Type:  OnlineSystem Int32  
PointNames
Type:  OnlineSystem String  
PointX
Type:  OnlineSystem Double  
PointY
Type:  OnlineSystem Double  
PointZ
Type:  OnlineSystem Double  

Return Value

Remarks

See Also