Assigns P-delta parameters to a link property.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int SetPDelta(
string Name,
ref double[] Value
)
Function SetPDelta ( _
Name As String, _
ByRef Value As Double() _
) As Integer
int SetPDelta(
String^ Name,
array<double>^% Value
)
Parameters
- Name
- Type:
System String
The name of an existing link property.
- Value
- Type:
System Double
This is an array of P-delta parameters
Value | PDelta Parameter |
---|
Value(0) | M2 P-delta to I-end of link as moment, M2I |
Value(1) | M2 P-delta to J-end of link as moment, M2J |
Value(2) | M3 P-delta to I-end of link as moment, M3I |
Value(3) | M3 P-delta to J-end of link as moment, M3J |
Return Value
Returns zero if the values are successfully assigned;
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim DOF() As Boolean
Dim Fixed() As Boolean
Dim Ke() As Double
Dim Ce() As Double
Dim MyValue() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ReDim DOF(5)
ReDim Fixed(5)
ReDim Ke(5)
ReDim Ce(5)
DOF(0) = True
Ke(0) = 12
ret = SapModel.PropLink.SetLinear("L1", DOF, Fixed, Ke, Ce, 0, 0)
ReDim MyValue(3)
MyValue(0) = 0.6
MyValue(1) = 0.4
MyValue(2) = 0.3
MyValue(3) = 0.2
ret = SapModel.PropLink.SetPDelta("L1", MyValue)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim DOF() As Boolean
Dim Fixed() As Boolean
Dim Ke() As Double
Dim Ce() As Double
Dim MyValue() As Double
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
'add link property
ReDim DOF(5)
ReDim Fixed(5)
ReDim Ke(5)
ReDim Ce(5)
DOF(0) = True
Ke(0) = 12
ret = SapModel.PropLink.SetLinear("L1", DOF, Fixed, Ke, Ce, 0, 0)
'set link property P-delta parameters
ReDim MyValue(3)
MyValue(0) = 0.6
MyValue(1) = 0.4
MyValue(2) = 0.3
MyValue(3) = 0.2
ret = SapModel.PropLink.SetPDelta("L1", MyValue)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub