Refreshes the view for the specified window(s).
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int RefreshView(
int Window = 0,
bool Zoom = true
)
int RefreshView(
int Window = 0,
bool Zoom = true
)
Function RefreshView ( _
Optional Window As Integer = 0, _
Optional Zoom As Boolean = True _
) As Integer
Function RefreshView ( _
Optional Window As Integer = 0, _
Optional Zoom As Boolean = True _
) As Integer
int RefreshView(
int Window = 0,
bool Zoom = true
)
int RefreshView(
int Window = 0,
bool Zoom = true
)
Parameters
- Window (Optional)
- Type:
System Int32
This is 0 meaning all windows or an existing window number.
It indicates the window(s) to have its view refreshed.
- Zoom (Optional)
- Type:
System Boolean
If this item is True, the window zoom is maintained when the view
is refreshed. If it is False, the zoom returns to a default zoom.
Return Value
Returns zero if the window views are successfully refreshed;
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.View.RefreshView()
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
'refresh view
ret = SapModel.View.RefreshView()
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub