cFrameObj GetLoadDistributed Method CSi API ETABS 2015
Retrieves the distributed load assignments to frame objects.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetLoadDistributed(
	string Name,
	ref int NumberItems,
	ref string[] FrameName,
	ref string[] LoadPat,
	ref int[] MyType,
	ref string[] CSys,
	ref int[] Dir,
	ref double[] RD1,
	ref double[] RD2,
	ref double[] Dist1,
	ref double[] Dist2,
	ref double[] Val1,
	ref double[] Val2,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: OnlineSystem String
The name of an existing frame object or group, depending on the value of the ItemType item.
NumberItems
Type: OnlineSystem Int32 
The total number of distributed loads retrieved for the specified frame objects.
FrameName
Type:  OnlineSystem String  
This is an array that includes the name of the frame object associated with each distributed load.
LoadPat
Type:  OnlineSystem String  
This is an array that includes the name of the load pattern associated with each distributed load.
MyType
Type:  OnlineSystem Int32  
This is an array that includes 1 or 2, indicating the type of distributed load.
  1. Force per unit length
  2. Moment per unit length
CSys
Type:  OnlineSystem String  
This is an array that includes the name of the coordinate system in which each distributed load is defined. It may be Local or the name of a defined coordinate system.
Dir
Type:  OnlineSystem Int32  
RD1
Type:  OnlineSystem Double  
RD2
Type:  OnlineSystem Double  
Dist1
Type:  OnlineSystem Double  
This is an array that includes the actual distance from the I-End of the frame object to the start of the distributed load. [L]
Dist2
Type:  OnlineSystem Double  
This is an array that includes the actual distance from the I-End of the frame object to the end of the distributed load. [L]
Val1
Type:  OnlineSystem Double  
This is an array that includes the load value at the start of the distributed load. [F/L] when MyType is 1 and [FL/L] when MyType is 2
Val2
Type:  OnlineSystem Double  
This is an array that includes the load value at the end of the distributed load. [F/L] when MyType is 1 and [FL/L] when MyType is 2
ItemType (Optional)
Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If this item is Objects, the assignments are retrieved for the frame object specified by the Name item.

If this item is Group, the assignments are retrieved for all frame objects in the group specified by the Name item.

If this item is SelectedObjects, the assignments are retrieved for all selected frame objects and the Name item is ignored.

Return Value

Returns zero if the load assignments are successfully retrieved, otherwise it returns a nonzero value.
Remarks

Examples

See Also