cFrameObj GetEndLengthOffset Method CSi API ETABS 2015
Retrieves the frame object end offsets along the 1-axis of the object.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetEndLengthOffset(
	string Name,
	ref bool AutoOffset,
	ref double Length1,
	ref double Length2,
	ref double RZ
)

Parameters

Name
Type: OnlineSystem String
The name of an existing frame object.
AutoOffset
Type: OnlineSystem Boolean 
If this item is True, the end length offsets are automatically determined by the program from object connectivity.
Length1
Type: OnlineSystem Double 
Length2
Type: OnlineSystem Double 
RZ
Type: OnlineSystem Double 
The rigid zone factor. This is the fraction of the end offset length assumed to be rigid for bending and shear deformations.

Return Value

Returns zero if the offsets are successfully retrieved, otherwise it returns a nonzero value.
Remarks

See Also