cDesignSteel GetSummaryResults_2 Method CSi API ETABS 2015

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetSummaryResults_2(
	string Name,
	ref int NumberItems,
	ref string[] FrameType,
	ref string[] DesignSect,
	ref string[] Status,
	ref string[] PMMCombo,
	ref double[] PMMRatio,
	ref double[] PRatio,
	ref double[] MMajRatio,
	ref double[] MMinRatio,
	ref string[] VMajCombo,
	ref double[] VMajRatio,
	ref string[] VMinCombo,
	ref double[] VMinRatio,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: OnlineSystem String
NumberItems
Type: OnlineSystem Int32 
FrameType
Type:  OnlineSystem String  
DesignSect
Type:  OnlineSystem String  
Status
Type:  OnlineSystem String  
PMMCombo
Type:  OnlineSystem String  
PMMRatio
Type:  OnlineSystem Double  
PRatio
Type:  OnlineSystem Double  
MMajRatio
Type:  OnlineSystem Double  
MMinRatio
Type:  OnlineSystem Double  
VMajCombo
Type:  OnlineSystem String  
VMajRatio
Type:  OnlineSystem Double  
VMinCombo
Type:  OnlineSystem String  
VMinRatio
Type:  OnlineSystem Double  
ItemType (Optional)
Type: ETABS2015 eItemType
See Also