cCaseStaticLinear SetInitialCase Method CSi API ETABS 2015
Sets the initial condition for the specified load case.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int SetInitialCase(
	string Name,
	string InitialCase
)

Parameters

Name
Type: OnlineSystem String
The name of an existing static linear load case.
InitialCase
Type: OnlineSystem String
This is blank, None, or the name of an existing analysis case. This item specifies if the load case starts from zero initial conditions, that is, an unstressed state, or if it starts using the stiffness that occurs at the end of a nonlinear static or nonlinear direct integration time history load case.

If the specified initial case is a nonlinear static or nonlinear direct integration time history load case, the stiffness at the end of that case is used. If the initial case is anything else, zero initial conditions are assumed.

Return Value

Returns zero if the initial condition is successfully set; otherwise it returns a nonzero value.
Remarks

Examples

See Also