cLinkObj GetLocalAxesAdvanced Method CSi API ETABS 2015
Retrieves advanced local axes assignment for link objects.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetLocalAxesAdvanced(
	string Name,
	ref bool Active,
	ref int AxVectOpt,
	ref string AxCSys,
	ref int[] AxDir,
	ref string[] AxPt,
	ref double[] AxVect,
	ref int Plane2,
	ref int PlVectOpt,
	ref string PlCSys,
	ref int[] PlDir,
	ref string[] PlPt,
	ref double[] PlVect
)

Parameters

Name
Type: OnlineSystem String
The name of an existing link object.
Active
Type: OnlineSystem Boolean 
This is True if advanced local axes exist
AxVectOpt
Type: OnlineSystem Int32 
This is 1, 2, or 3, indicating the axis reference vector option. This item applies only when the Active item is True.
ValueAxVectOpt
1Coordinate direction
2Two joints
3User vector
AxCSys
Type: OnlineSystem String 
The coordinate system used to define the axis reference vector coordinate directions and the axis user vector. This item applies when the Active item is True and the AxVectOpt item is 1 or 3.
AxDir
Type:  OnlineSystem Int32  
AxPt
Type:  OnlineSystem String  
This is an array dimensioned to 1 (2 strings), indicating the labels of two joints that define the axis reference vector. Either of these joints may be specified as None to indicate the center of the specified object. If both joints are specified as None, they are not used to define the axis reference vector. This item applies when the Active item is True and the AxVectOpt item is 2.
AxVect
Type:  OnlineSystem Double  
This is an array dimensioned to 2 (3 doubles) that defines the axis reference vector. This item applies when the Active item is True and the AxVectOpt item is 3.
Plane2
Type: OnlineSystem Int32 
This is 12 or 13, indicating that the local plane determined by the plane reference vector is the 1-2 or 1-3 plane. This item applies only when the Active item is True.
PlVectOpt
Type: OnlineSystem Int32 
This is 1, 2, or 3, indicating the plane reference vector option. This item applies only when the Active item is True.
ValuePlVectOpt
1Coordinate direction
2Two joints
3User vector
PlCSys
Type: OnlineSystem String 
PlDir
Type:  OnlineSystem Int32  
PlPt
Type:  OnlineSystem String  
This is an array dimensioned to 1 (2 strings), indicating the labels of two joints that define the plane reference vector. Either of these joints may be specified as None to indicate the center of the specified object. If both joints are specified as None, they are not used to define the plane reference vector. This item applies when the Active item is True and the PlVectOpt item is 2.
PlVect
Type:  OnlineSystem Double  
This is an array dimensioned to 2 (3 doubles) that defines the plane reference vector. This item applies when the Active item is True and the PlVectOpt item is 3.

Return Value

Returns zero if the advanced local axes assignments are retrieved successfully; otherwise, it returns a nonzero value.
Remarks

Examples

See Also