Retrieves the names of all defined link properties of the specified type.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int GetNameList(
ref int NumberNames,
ref string[] MyName,
eLinkPropType PropType =
)
Function GetNameList ( _
ByRef NumberNames As Integer, _
ByRef MyName As String(), _
Optional PropType As eLinkPropType = _
) As Integer
int GetNameList(
int% NumberNames,
array<String^>^% MyName,
eLinkPropType PropType =
)
Parameters
- NumberNames
- Type:
System Int32
The number of link property names retrieved by the program.
- MyName
- Type:
System String
This is a one-dimensional array of link property names.
The MyName array is created as a dynamic, zero-based, array by the API user:
Dim MyName() as StringThe array is dimensioned to (NumberNames - 1) inside the program,
filled with the names, and returned to the API user.
- PropType (Optional)
- Type: ETABS2015 eLinkPropType
This optional value is one of the items in the
eLinkPropType enumeration.
If no value is input for PropType, names are returned for all link properties
in the model regardless of type.
Return Value
Returns zero if the names are successfully retrieved;
otherwise it returns nonzero.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim DOF() As Boolean
Dim Fixed() As Boolean
Dim Ke() As Double
Dim Ce() As Double
Dim NumberNames As Integer
Dim MyName() As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ReDim DOF(5)
ReDim Fixed(5)
ReDim Ke(5)
ReDim Ce(5)
DOF(0) = True
Ke(0) = 12
ret = SapModel.PropLink.SetLinear("L1", DOF, Fixed, Ke, Ce, 0, 0)
ret = SapModel.PropLink.GetNameList(NumberNames, MyName)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim DOF() As Boolean
Dim Fixed() As Boolean
Dim Ke() As Double
Dim Ce() As Double
Dim NumberNames As Integer
Dim MyName() As String
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
'add link property
ReDim DOF(5)
ReDim Fixed(5)
ReDim Ke(5)
ReDim Ce(5)
DOF(0) = True
Ke(0) = 12
ret = SapModel.PropLink.SetLinear("L1", DOF, Fixed, Ke, Ce, 0, 0)
'get link property names
ret = SapModel.PropLink.GetNameList(NumberNames, MyName)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub