Retrieves the local axis angle assignment for link objects.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int GetLocalAxes(
string Name,
ref double Ang,
ref bool Advanced
)
Function GetLocalAxes ( _
Name As String, _
ByRef Ang As Double, _
ByRef Advanced As Boolean _
) As Integer
int GetLocalAxes(
String^ Name,
double% Ang,
bool% Advanced
)
Parameters
- Name
- Type:
System String
The name of an existing link object.
- Ang
- Type:
System Double
This is the angle that the local 2 and 3 axes are rotated about the
positive local 1 axis, from the default orientation. The rotation for a positive
angle appears counter clockwise when the local +1 axis is pointing toward you. [deg].
- Advanced
- Type:
System Boolean
This item is True if the link object local axes orientation
was obtained using advanced local axes parameters.
Return Value
Returns zero if the assignment is successfully retrieved;
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name As String
Dim Ang As Double
Dim Advanced As boolean
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.LinkObj.AddByPoint("1", "5", Name)
ret = SapModel.LinkObj.SetLocalAxes(Name, 30)
ret = SapModel.LinkObj.GetLocalAxes(Name, Ang, Advanced)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name As String
Dim Ang As Double
Dim Advanced As boolean
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
'add link object by points
ret = SapModel.LinkObj.AddByPoint("1", "5", Name)
'assign link local axis angle
ret = SapModel.LinkObj.SetLocalAxes(Name, 30)
'get link local axis angle
ret = SapModel.LinkObj.GetLocalAxes(Name, Ang, Advanced)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub