Retrieves the grid system specified by the Name item.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int GetGridSys(
string Name,
ref double x,
ref double y,
ref double RZ
)
Function GetGridSys ( _
Name As String, _
ByRef x As Double, _
ByRef y As Double, _
ByRef RZ As Double _
) As Integer
int GetGridSys(
String^ Name,
double% x,
double% y,
double% RZ
)
Parameters
- Name
- Type:
System String
The name of an existing grid system.
- x
- Type:
System Double
The global X grid of the origin of the grid system. [L]
- y
- Type:
System Double
The global Y grid of the origin of the grid system. [L]
- RZ
- Type:
System Double
The rotation of an axis of the new grid system relative to the
global grid system is defined as follows:
(1) Rotate the grid system about the positive global Z-axis
as defined by the RZ item. [deg]
Return Value
Returns zero if the grid system data is successfully retrieved,
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.GridSys.SetGridSys("GridSysA", 1000, 1000, 0, 0, 0, 0)
ret = SapModel.GridSys.GetGridSys("GridSysA", x, y, z, RZ, RY, RX)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
'define new grid system
ret = SapModel.GridSys.SetGridSys("GridSysA", 1000, 1000, 0, 0, 0, 0)
'get new grid system data
ret = SapModel.GridSys.GetGridSys("GridSysA", x, y, z, RZ, RY, RX)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub