cFrameObj SetDesignProcedure Method CSi API ETABS 2015
Sets the design procedure for frame objects.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int SetDesignProcedure(
	string Name,
	int MyType,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: OnlineSystem String
The name of an existing frame object or group, depending on the value of the ItemType item.
MyType
Type: OnlineSystem Int32
This is an integer from the list below, indicating the design procedure type desired for the specified frame object.
  • Program determined = 0
  • Steel Frame Design = 1
  • Concrete Frame Design = 2
  • Composite Beam Design = 3
  • Steel Joist Design = 4
  • No Design = 7
  • Composite Column Design = 13
ItemType (Optional)
Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If this item is Objects, the assignment is made to the frame object specified by the Name item.

If this item is Group, the assignment is made to all frame objects in the group specified by the Name item.

If this item is SelectedObjects, the assignment is made to all selected frame objects and the Name item is ignored.

Return Value

Returns zero if the design procedure is successfully set; otherwise it returns a nonzero value.
Remarks

Examples

See Also