Designates an area object(s) as an opening.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int SetOpening(
string Name,
bool IsOpening,
eItemType ItemType = eItemType.Objects
)
Function SetOpening ( _
Name As String, _
IsOpening As Boolean, _
Optional ItemType As eItemType = eItemType.Objects _
) As Integer
int SetOpening(
String^ Name,
bool IsOpening,
eItemType ItemType = eItemType::Objects
)
Parameters
- Name
- Type:
System String
The name of an existing area object or group, depending on the value
of the ItemType item.
- IsOpening
- Type:
System Boolean
This item should be set to True if the specified area object(s) is to be an opening,
otherwise it should be False.
- ItemType (Optional)
- Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignment is made to the area object
specified by the Name item.
If this item is Group, the assignment is made to all area objects
in the group specified by the Name item.
If this item is SelectedObjects, the assignment is made to all selected
area objects, and the Name item is ignored.
Return Value
Returns zero if the opening is successfully assigned;
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.AreaObj.SetOpening("3", True)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
'designate an area object as an opening
ret = SapModel.AreaObj.SetOpening("3", True)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub