Assigns frame object insertion point data. The assignments include
the cardinal point and end joint offsets.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax
Parameters
- Name
- Type:
System String
The name of an existing frame object or group, depending on the value of the ItemType item.
- CardinalPoint
- Type:
System Int32
This is a numeric value from 1 to 11 that specifies the cardinal point for the frame object. The cardinal point specifies the relative position of the frame section on the line representing the frame object.- bottom left
- bottom center
- bottom right
- middle left
- middle center
- middle right
- top left
- top center
- top right
- centroid
- shear center
- Mirror2
- Type:
System Boolean
If this item is True, the frame object section is assumed to be mirrored (flipped) about its local 2-axis.
- StiffTransform
- Type:
System Boolean
If this item is True, the frame object stiffness is transformed for cardinal point and joint offsets from the frame section centroid.
- Offset1
- Type:
System Double
This is an array of three joint offset distances, in the coordinate directions specified by CSys, at the I-End of the frame object. [L]- Offset1(0) = Offset in the 1-axis or X-axis direction
- Offset1(1) = Offset in the 2-axis or Y-axis direction
- Offset1(2) = Offset in the 3-axis or Z-axis direction
- Offset2
- Type:
System Double
This is an array of three joint offset distances, in the coordinate directions specified by CSys, at the J-End of the frame object. [L]- Offset2(0) = Offset in the 1-axis or X-axis direction
- Offset2(1) = Offset in the 2-axis or Y-axis direction
- Offset2(2) = Offset in the 3-axis or Z-axis direction
- CSys (Optional)
- Type:
System String
This is Local or the name of a defined coordinate system. It is the coordinate system in which the Offset1 and Offset2 items are specified.
- ItemType (Optional)
- Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignment is made to the frame object specified by the Name item.
If this item is Group, the assignment is made to all frame objects in the group specified by the Name item.
If this item is SelectedObjects, the assignment is made to all selected frame objects and the Name item is ignored.
Return Value
Returns zero if the insertion point data is successfully assigned, otherwise it returns a nonzero value.Remarks
Examples
See Also