cFrameObj SetLoadPoint Method CSi API ETABS 2015
Assigns point loads to frame objects.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int SetLoadPoint(
	string Name,
	string LoadPat,
	int MyType,
	int Dir,
	double Dist,
	double Val,
	string CSys = "Global",
	bool RelDist = true,
	bool Replace = true,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: OnlineSystem String
The name of an existing frame object or group, depending on the value of the ItemType item.
LoadPat
Type: OnlineSystem String
The name of a defined load pattern.
MyType
Type: OnlineSystem Int32
This is 1 or 2, indicating the type of point load.
  1. Force
  2. Moment
Dir
Type: OnlineSystem Int32
Dist
Type: OnlineSystem Double
Val
Type: OnlineSystem Double
CSys (Optional)
Type: OnlineSystem String
This is Local or the name of a defined coordinate system. It is the coordinate system in which the loads are specified.
RelDist (Optional)
Type: OnlineSystem Boolean
If this item is True, the specified dist item is a relative distance, otherwise it is an actual distance.
Replace (Optional)
Type: OnlineSystem Boolean
If this item is True, all previous loads, if any, assigned to the specified frame object(s), in the specified load pattern, are deleted before making the new assignment.
ItemType (Optional)
Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If this item is Objects, the assignment is made to the frame object specified by the Name item.

If this item is Group, the assignment is made to all frame objects in the group specified by the Name item.

If this item is SelectedObjects, the assignment is made to all selected frame objects and the Name item is ignored.

Return Value

Returns zero if the loads are successfully assigned, otherwise it returns a nonzero value.
Remarks

Examples

See Also