cFrameObj Delete Method CSi API ETABS 2015
Deletes frame objects.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int Delete(
	string Name,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: OnlineSystem String
The name of an existing frame object or group depending on the value of the ItemType item.
ItemType (Optional)
Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If this item is Objects, the frame object specified by the Name item is deleted.

If this item is Group, all of the frame objects in the group specified by the Name item are deleted.

If this item is SelectedObjects, all selected frame objects are deleted, and the Name item is ignored.

Return Value

Returns zero if the frame object is successfully deleted, otherwise it returns a nonzero value.
Remarks

Examples

See Also