Adds or removes frame objects from a specified group.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int SetGroupAssign(
string Name,
string GroupName,
bool Remove = false,
eItemType ItemType = eItemType.Objects
)
Function SetGroupAssign ( _
Name As String, _
GroupName As String, _
Optional Remove As Boolean = False, _
Optional ItemType As eItemType = eItemType.Objects _
) As Integer
int SetGroupAssign(
String^ Name,
String^ GroupName,
bool Remove = false,
eItemType ItemType = eItemType::Objects
)
Parameters
- Name
- Type:
System String
The name of an existing point object or group depending on the
value of the ItemType item.
- GroupName
- Type:
System String
The name of an existing group to which the assignment is made.
- Remove (Optional)
- Type:
System Boolean
- ItemType (Optional)
- Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the frame object
specified by the Name item is added or removed
from the group specified by the GroupName item.
If this item is Group, all frame objects in
the group specified by the Name item are added
or removed from the group specified by the GroupName item.
If this item is SelectedObjects, all selected
frame objects are added or removed from the group specified by
the GroupName item and the Name item is ignored.
Return Value
Returns zero if the group assignment is successful,
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.GroupDef.SetGroup("Group1")
ret = SapModel.FrameObj.SetGroupAssign("8", "Group1")
ret = SapModel.FrameObj.SetGroupAssign("10", "Group1")
ret = SapModel.SelectObj.Group("Group1")
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
'define new group
ret = SapModel.GroupDef.SetGroup("Group1")
'add frame objects to group
ret = SapModel.FrameObj.SetGroupAssign("8", "Group1")
ret = SapModel.FrameObj.SetGroupAssign("10", "Group1")
'select objects in group
ret = SapModel.SelectObj.Group("Group1")
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub