cAreaObj SetDiaphragm Method CSi API ETABS 2015
Assigns a diaphragm to a specified area object

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int SetDiaphragm(
	string Name,
	string DiaphragmName
)

Parameters

Name
Type: OnlineSystem String
The name of an existing area object
DiaphragmName
Type: OnlineSystem String
This the name of an existing diaphragm to be assigned to the specified area object. If it is "None", no diaphragm will be assigned to the area object.

Return Value

Returns zero if the diaphragm is successfully assigned; otherwise it returns a nonzero value.
Remarks

Examples

See Also