cLoadPatterns GetAutoSeismicCode Method CSi API ETABS 2015
Retrieves the code name used for auto seismic parameters in Quake-type load patterns.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetAutoSeismicCode(
	string Name,
	ref string CodeName
)

Parameters

Name
Type: OnlineSystem String
The name of an existing Quake-type load pattern.
CodeName
Type: OnlineSystem String 
This is either blank or the name code used for the auto seismic parameters. Blank means no auto seismic load is specified for the Quake-type load pattern.

Return Value

Returns zero if the code is successfully retrieved; otherwise it returns a nonzero value.
Remarks

An error is returned if the specified load pattern is not a Quake-type load pattern.
Examples

See Also