Sets the mass source for the model.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int SetMassSource_1(
ref bool IncludeElements,
ref bool IncludeAddedMass,
ref bool IncludeLoads,
int NumberLoads,
ref string[] LoadPat,
ref double[] sf
)
int SetMassSource_1(
ref bool IncludeElements,
ref bool IncludeAddedMass,
ref bool IncludeLoads,
int NumberLoads,
ref string[] LoadPat,
ref double[] sf
)
Function SetMassSource_1 ( _
ByRef IncludeElements As Boolean, _
ByRef IncludeAddedMass As Boolean, _
ByRef IncludeLoads As Boolean, _
NumberLoads As Integer, _
ByRef LoadPat As String(), _
ByRef sf As Double() _
) As Integer
int SetMassSource_1(
bool% IncludeElements,
bool% IncludeAddedMass,
bool% IncludeLoads,
int NumberLoads,
array<String^>^% LoadPat,
array<double>^% sf
)
int SetMassSource_1(
bool% IncludeElements,
bool% IncludeAddedMass,
bool% IncludeLoads,
int NumberLoads,
array<String^>^% LoadPat,
array<double>^% sf
)
Parameters
- IncludeElements
- Type:
System Boolean
Include element self mass
- IncludeAddedMass
- Type:
System Boolean
Include additional masses
- IncludeLoads
- Type:
System Boolean
Include specified loads
- NumberLoads
- Type:
System Int32
The number of load patterns from which mass is obtained.
This item applies only when IncludeLoads is True.
- LoadPat
- Type:
System String
This is an array of the names of the load patterns from which mass is obtained.
This item applies only when IncludeLoads is True.
- sf
- Type:
System Double
This is an array of load patterns multipliers used to calculate the mass.
This item applies only when IncludeLoads is True.
Return Value
Returns zero if the mass source is successfully set;
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim MyLoadPat() As String
Dim MySF() As Double
Dim MyOption As Integer
Dim NumberLoads As Integer
Dim LoadPat() As String
Dim sf() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ReDim MyLoadPat(1)
ReDim MySF(1)
MyLoadPat(0) = "DEAD"
MyLoadPat(1) = "LIVE"
MySF(0) = 1
MySF(1) = 0.2
ret = SapModel.PropMaterial.SetMassSource(3, 2, MyLoadPat, MySF)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim MyLoadPat() As String
Dim MySF() As Double
Dim MyOption As Integer
Dim NumberLoads As Integer
Dim LoadPat() As String
Dim sf() As Double
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
'set mass source
ReDim MyLoadPat(1)
ReDim MySF(1)
MyLoadPat(0) = "DEAD"
MyLoadPat(1) = "LIVE"
MySF(0) = 1
MySF(1) = 0.2
ret = SapModel.PropMaterial.SetMassSource(3, 2, MyLoadPat, MySF)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub