Retrieves the story information for the current tower
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int GetStories(
ref int NumberStories,
ref string[] StoryNames,
ref double[] StoryElevations,
ref double[] StoryHeights,
ref bool[] IsMasterStory,
ref string[] SimilarToStory,
ref bool[] SpliceAbove,
ref double[] SpliceHeight
)
int GetStories(
ref int NumberStories,
ref string[] StoryNames,
ref double[] StoryElevations,
ref double[] StoryHeights,
ref bool[] IsMasterStory,
ref string[] SimilarToStory,
ref bool[] SpliceAbove,
ref double[] SpliceHeight
)
Function GetStories ( _
ByRef NumberStories As Integer, _
ByRef StoryNames As String(), _
ByRef StoryElevations As Double(), _
ByRef StoryHeights As Double(), _
ByRef IsMasterStory As Boolean(), _
ByRef SimilarToStory As String(), _
ByRef SpliceAbove As Boolean(), _
ByRef SpliceHeight As Double() _
) As Integer
Function GetStories ( _
ByRef NumberStories As Integer, _
ByRef StoryNames As String(), _
ByRef StoryElevations As Double(), _
ByRef StoryHeights As Double(), _
ByRef IsMasterStory As Boolean(), _
ByRef SimilarToStory As String(), _
ByRef SpliceAbove As Boolean(), _
ByRef SpliceHeight As Double() _
) As Integer
int GetStories(
int% NumberStories,
array<String^>^% StoryNames,
array<double>^% StoryElevations,
array<double>^% StoryHeights,
array<bool>^% IsMasterStory,
array<String^>^% SimilarToStory,
array<bool>^% SpliceAbove,
array<double>^% SpliceHeight
)
int GetStories(
int% NumberStories,
array<String^>^% StoryNames,
array<double>^% StoryElevations,
array<double>^% StoryHeights,
array<bool>^% IsMasterStory,
array<String^>^% SimilarToStory,
array<bool>^% SpliceAbove,
array<double>^% SpliceHeight
)
Parameters
- NumberStories
- Type:
System Int32
The number of stories. All output arrays have length (NumberStories + 1), because
they include values for "Base" , which is not a story.
- StoryNames
- Type:
System String
The names of the stories. This array will include "Base" .
- StoryElevations
- Type:
System Double
The story elevations. The first value is the "Base" elevation.
- StoryHeights
- Type:
System Double
The story heights. The first value is the "Base" height.
- IsMasterStory
- Type:
System Boolean
Whether the story is a master story
- SimilarToStory
- Type:
System String
If the story is not a master story, which master story the story is similar to
- SpliceAbove
- Type:
System Boolean
This is True if the story has a splice height, and False otherwise
- SpliceHeight
- Type:
System Double
The story splice height
Return Value
Returns zero if the story data is successfully retrieved,
otherwise returns nonzero.
To change the current tower, use
SetActiveTower(String)Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim NumberStories As Integer
Dim StoryNames() As String
Dim StoryHeights() As Double
Dim StoryElevations() As Double
Dim IsMasterStory() As Boolean
Dim SimilarToStory() As String
Dim SpliceAbove() As Boolean
Dim SpliceHeight() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.Story.GetStories(NumberStories, StoryNames, StoryHeights, StoryElevations, _
IsMasterStory, SimilarToStory, SpliceAbove, SpliceHeight)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim NumberStories As Integer
Dim StoryNames() As String
Dim StoryHeights() As Double
Dim StoryElevations() As Double
Dim IsMasterStory() As Boolean
Dim SimilarToStory() As String
Dim SpliceAbove() As Boolean
Dim SpliceHeight() As Double
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
'get stories
ret = SapModel.Story.GetStories(NumberStories, StoryNames, StoryHeights, StoryElevations, _
IsMasterStory, SimilarToStory, SpliceAbove, SpliceHeight)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub