cSapModel SetModelIsLocked Method CSi API ETABS 2015
Locks or unlocks the model.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int SetModelIsLocked(
	bool Lockit
)

Parameters

Lockit
Type: OnlineSystem Boolean
The item is True if the model is to be locked and False if it is to be unlocked.

Return Value

Returns zero if the locked status of the model is successfully set. Otherwise it returns a nonzero value.
Remarks

With some exceptions, definitions and assignments can not be changed in a model while the model is locked. If an attempt is made to change a definition or assignment while the model is locked and that change is not allowed in a locked model, an error will be returned.
Examples

See Also