cAnalysisResults SpandrelForce Method CSi API ETABS 2015
Retrieves spandrel forces for any defined spandrel objects in the model

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int SpandrelForce(
	ref int NumberResults,
	ref string[] StoryName,
	ref string[] SpandrelName,
	ref string[] LoadCase,
	ref string[] Location,
	ref double[] P,
	ref double[] V2,
	ref double[] V3,
	ref double[] T,
	ref double[] M2,
	ref double[] M3
)

Parameters

NumberResults
Type: OnlineSystem Int32 
The total number of results returned by the program
StoryName
Type:  OnlineSystem String  
The story name of the spandrel object
SpandrelName
Type:  OnlineSystem String  
The name of the spandrel object
LoadCase
Type:  OnlineSystem String  
The names of the load case
Location
Type:  OnlineSystem String  
The location on the spandrel, either "Left" or "Right", of the result being reported
P
Type:  OnlineSystem Double  
The axial force [F]
V2
Type:  OnlineSystem Double  
The shear force in the local 2 direction [F]
V3
Type:  OnlineSystem Double  
The shear force in the local 3 direction [F]
T
Type:  OnlineSystem Double  
The torsion [FL]
M2
Type:  OnlineSystem Double  
The moment about the local 2 axis [FL]
M3
Type:  OnlineSystem Double  
The moment about the local 3 axis [FL]

Return Value

Returns zero if the results are successfully retrieved; otherwise returns nonzero
Remarks

See Also