Retrieves the grid system transformation matrix.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int GetTransformationMatrix(
string Name,
ref double[] Value
)
Function GetTransformationMatrix ( _
Name As String, _
ByRef Value As Double() _
) As Integer
int GetTransformationMatrix(
String^ Name,
array<double>^% Value
)
Parameters
- Name
- Type:
System String
The name of an existing grid system.
- Value
- Type:
System Double
Value is an array of nine direction cosines that define
the transformation matrix from the specified grid system
to the global grid system.
Return Value
Returns zero if the grid system transformation matrix is successfully returned,
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.GridSys.SetGridSys("GridSysA", 1000, 1000, 0, 0, 0, 0)
ReDim Value(8)
ret = SapModel.GridSys.GetTransformationMatrix("GridSysA", Value)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
'define new grid system
ret = SapModel.GridSys.SetGridSys("GridSysA", 1000, 1000, 0, 0, 0, 0)
'get grid system transformation matrix
ReDim Value(8)
ret = SapModel.GridSys.GetTransformationMatrix("GridSysA", Value)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub