cLinkObj GetNameListOnStory Method CSi API ETABS 2015
Retrieves the names of the defined link objects on a given story.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetNameListOnStory(
	string StoryName,
	ref int NumberNames,
	ref string[] MyName
)

Parameters

StoryName
Type: OnlineSystem String
The name of an existing story.
NumberNames
Type: OnlineSystem Int32 
The number of link object names retrieved by the program.
MyName
Type:  OnlineSystem String  
This is a one-dimensional array of link object names. The MyName array is created as a dynamic, zero-based, array by the API user: Dim MyName() as String

The array is dimensioned to (NumberNames - 1) inside the program, filled with the names, and returned to the API user.

Return Value

Returns zero if the names are successfully retrieved; otherwise it returns nonzero.
Remarks

Examples

See Also