cPropArea GetSlabWaffle Method CSi API ETABS 2015
Retrieves property data for a waffle slab section.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetSlabWaffle(
	string Name,
	ref double OverallDepth,
	ref double SlabThickness,
	ref double StemWidthTop,
	ref double StemWidthBot,
	ref double RibSpacingDir1,
	ref double RibSpacingDir2
)

Parameters

Name
Type: OnlineSystem String
The name of an existing waffle slab property.
OverallDepth
Type: OnlineSystem Double 
Overall Depth
SlabThickness
Type: OnlineSystem Double 
Slab Thickness
StemWidthTop
Type: OnlineSystem Double 
Stem Width at Top
StemWidthBot
Type: OnlineSystem Double 
Stem Width at Bottom
RibSpacingDir1
Type: OnlineSystem Double 
Spacing of Ribs that are Parallel to Slab 1-Axis
RibSpacingDir2
Type: OnlineSystem Double 
Spacing of Ribs that are Parallel to Slab 2-Axis

Return Value

The function returns zero if the property data is successfully retrieved; otherwise it returns a nonzero value.
Remarks

Examples

See Also