cAreaObj AddByCoord Method CSi API ETABS 2015
Adds a new area object, defining points at the specified coordinates.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int AddByCoord(
	int NumberPoints,
	ref double[] X,
	ref double[] Y,
	ref double[] Z,
	ref string Name,
	string PropName = "Default",
	string UserName = "",
	string CSys = "Global"
)

Parameters

NumberPoints
Type: OnlineSystem Int32
The number of points in the area object.
X
Type:  OnlineSystem Double  
Y
Type:  OnlineSystem Double  
Z
Type:  OnlineSystem Double  
Name
Type: OnlineSystem String 
This is the name that the program ultimately assigns to the area object. If no userName is specified, the program assigns a default name to the area object. If a userName is specified and that name is not used for another area object, the userName is assigned to the area object; otherwise a default name is assigned to the area object.
PropName (Optional)
Type: OnlineSystem String
This is Default, None or the name of a defined area property.

If it is Default, the program assigns a default area property to the area object. If it is None, no area property is assigned to the area object. If it is the name of a defined area property, that property is assigned to the area object.

UserName (Optional)
Type: OnlineSystem String
CSys (Optional)
Type: OnlineSystem String
The name of the coordinate system in which the area object point coordinates are defined.

Return Value

Returns zero if the area object is successfully added, otherwise it returns a nonzero value.
Remarks

Examples

See Also