Retrieves property data for a solid-slab deck section.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int GetDeckSolidSlab(
string Name,
ref double SlabDepth,
ref double ShearStudDia,
ref double ShearStudHt,
ref double ShearStudFu
)
Function GetDeckSolidSlab ( _
Name As String, _
ByRef SlabDepth As Double, _
ByRef ShearStudDia As Double, _
ByRef ShearStudHt As Double, _
ByRef ShearStudFu As Double _
) As Integer
int GetDeckSolidSlab(
String^ Name,
double% SlabDepth,
double% ShearStudDia,
double% ShearStudHt,
double% ShearStudFu
)
Return Value
The function returns zero if the property data is successfully retrieved;
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim DeckType As ETABS2013.eDeckType
Dim ShellType As ETABS2013.eShellType
Dim MatProp As String
Dim Thickness As Double
Dim Color As Integer
Dim Notes As String
Dim GUID As String
Dim SlabDepth As Double
Dim ShearStudDia As Double
Dim ShearStudHt As Double
Dim ShearStudFu As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropArea.SetDeck("MyShellProp1A", ETABS2013.eDeckType.SolidSlab, ETABS2013.eShellType.ShellThin, "4000Psi", 14)
ret = SapModel.PropArea.SetDeckSolidSlab(Name:="MyShellProp1A", SlabDepth:=3.5, ShearStudDia:=0.75, ShearStudHt:=6, ShearStudFu:=65000)
ret = SapModel.PropArea.GetDeck("MyShellProp1A", DeckType, ShellType, MatProp, Thickness, Color, Notes, GUID)
ret = SapModel.PropArea.GetDeckSolidSlab("MyShellProp1A", SlabDepth, ShearStudDia, ShearStudHt, ShearStudFu)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim DeckType As ETABS2013.eDeckType
Dim ShellType As ETABS2013.eShellType
Dim MatProp As String
Dim Thickness As Double
Dim Color As Integer
Dim Notes As String
Dim GUID As String
Dim SlabDepth As Double
Dim ShearStudDia As Double
Dim ShearStudHt As Double
Dim ShearStudFu As Double
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
'set new area property
ret = SapModel.PropArea.SetDeck("MyShellProp1A", ETABS2013.eDeckType.SolidSlab, ETABS2013.eShellType.ShellThin, "4000Psi", 14)
'set new area property
ret = SapModel.PropArea.SetDeckSolidSlab(Name:="MyShellProp1A", SlabDepth:=3.5, ShearStudDia:=0.75, ShearStudHt:=6, ShearStudFu:=65000)
'get area property data
ret = SapModel.PropArea.GetDeck("MyShellProp1A", DeckType, ShellType, MatProp, Thickness, Color, Notes, GUID)
'get area property data
ret = SapModel.PropArea.GetDeckSolidSlab("MyShellProp1A", SlabDepth, ShearStudDia, ShearStudHt, ShearStudFu)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub