cFrameObj GetModifiers Method CSi API ETABS 2015
Retrieves the frame modifier assignment for frame objects. The default value for all modifiers is one.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetModifiers(
	string Name,
	ref double[] Value
)

Parameters

Name
Type: OnlineSystem String
The name of an existing frame object
Value
Type:  OnlineSystem Double  
This is an array of eight unitless modifiers:
ValueModifier
Value(0)Cross sectional area modifier
Value(1)Shear area in local 2 direction modifier
Value(2)Shear area in local 3 direction modifier
Value(3)Torsional constant modifier
Value(4)Moment of inertia about local 2 axis modifier
Value(5)Moment of inertia about local 3 axis modifier
Value(6)Mass modifier
Value(7)Weight modifier

Return Value

Returns zero if the modifier assignments are successfully retrieved, otherwise it returns a nonzero value
Remarks

Examples

See Also