Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim DeckType As ETABS2013.eDeckType
Dim ShellType As ETABS2013.eShellType
Dim MatProp As String
Dim Thickness As Double
Dim Color As Integer
Dim Notes As String
Dim GUID As String
Dim SlabDepth As Double
Dim RibDepth As Double
Dim RibWidthTop As Double
Dim RibWidthBot As Double
Dim RibSpacing As Double
Dim DeckShearThickness As Double
Dim DeckUnitWeight As Double
Dim ShearStudDia As Double
Dim ShearStudHt As Double
Dim ShearStudFu As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropArea.SetDeck("MyShellProp1A", ETABS2013.eDeckType.Filled, ETABS2013.eShellType.ShellThin, "4000Psi", 14)
ret = SapModel.PropArea.SetDeckFilled(Name:="MyShellProp1A", SlabDepth:=15.6, RibDepth:=1.1, RibWidthTop:=2.3, RibWidthBot:=2.4, _
RibSpacing:=7, ShearThickness:=5, UnitWeight:=3.1, ShearStudDia:=1.02, ShearStudHt:=4.4, ShearStudFu:=2.01)
ret = SapModel.PropArea.GetDeck("MyShellProp1A", DeckType, ShellType, MatProp, Thickness, Color, Notes, GUID)
ret = SapModel.PropArea.GetDeckFilled("MyShellProp1A", SlabDepth, RibDepth, RibWidthTop, RibWidthBot, _
RibSpacing, DeckShearThickness, DeckUnitWeight, ShearStudDia, ShearStudHt, ShearStudFu)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim DeckType As ETABS2013.eDeckType
Dim ShellType As ETABS2013.eShellType
Dim MatProp As String
Dim Thickness As Double
Dim Color As Integer
Dim Notes As String
Dim GUID As String
Dim SlabDepth As Double
Dim RibDepth As Double
Dim RibWidthTop As Double
Dim RibWidthBot As Double
Dim RibSpacing As Double
Dim DeckShearThickness As Double
Dim DeckUnitWeight As Double
Dim ShearStudDia As Double
Dim ShearStudHt As Double
Dim ShearStudFu As Double
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
'set new area property
ret = SapModel.PropArea.SetDeck("MyShellProp1A", ETABS2013.eDeckType.Filled, ETABS2013.eShellType.ShellThin, "4000Psi", 14)
'set new area property
ret = SapModel.PropArea.SetDeckFilled(Name:="MyShellProp1A", SlabDepth:=15.6, RibDepth:=1.1, RibWidthTop:=2.3, RibWidthBot:=2.4, _
RibSpacing:=7, ShearThickness:=5, UnitWeight:=3.1, ShearStudDia:=1.02, ShearStudHt:=4.4, ShearStudFu:=2.01)
'get area property data
ret = SapModel.PropArea.GetDeck("MyShellProp1A", DeckType, ShellType, MatProp, Thickness, Color, Notes, GUID)
'get area property data
ret = SapModel.PropArea.GetDeckFilled("MyShellProp1A", SlabDepth, RibDepth, RibWidthTop, RibWidthBot, _
RibSpacing, DeckShearThickness, DeckUnitWeight, ShearStudDia, ShearStudHt, ShearStudFu)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub