Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim SlabType As ETABS2013.eSlabType
Dim ShellType As ETABS2013.eShellType
Dim MatProp As String
Dim Thickness As Double
Dim Color As Integer
Dim Notes As String
Dim GUID As String
Dim OverallDepth As Double
Dim SlabThickness As Double
Dim StemWidthTop As Double
Dim StemWidthBot As Double
Dim RibSpacing As Double
Dim RibsParallelTo As Integer
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropArea.SetSlab("MyShellProp1A", ETABS2013.eSlabType.Ribbed, ETABS2013.eShellType.ShellThin, "4000Psi", 14.2)
ret = SapModel.PropArea.SetSlabRibbed(Name:="MyShellProp1A", OverallDepth:=11.1, SlabThickness:=22.2, StemWidthTop:=33.3, StemWidthBot:=44.4, RibSpacing:=55.5, RibsParallelTo:=2)
ret = SapModel.PropArea.GetSlab("MyShellProp1A", SlabType, ShellType, MatProp, Thickness, Color, Notes, GUID)
ret = SapModel.PropArea.GetSlabRibbed("MyShellProp1A", OverallDepth, SlabThickness, StemWidthTop, StemWidthBot, RibSpacing, RibsParallelTo)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim SlabType As ETABS2013.eSlabType
Dim ShellType As ETABS2013.eShellType
Dim MatProp As String
Dim Thickness As Double
Dim Color As Integer
Dim Notes As String
Dim GUID As String
Dim OverallDepth As Double
Dim SlabThickness As Double
Dim StemWidthTop As Double
Dim StemWidthBot As Double
Dim RibSpacing As Double
Dim RibsParallelTo As Integer
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
'set new area property
ret = SapModel.PropArea.SetSlab("MyShellProp1A", ETABS2013.eSlabType.Ribbed, ETABS2013.eShellType.ShellThin, "4000Psi", 14.2)
'set new area property
ret = SapModel.PropArea.SetSlabRibbed(Name:="MyShellProp1A", OverallDepth:=11.1, SlabThickness:=22.2, StemWidthTop:=33.3, StemWidthBot:=44.4, RibSpacing:=55.5, RibsParallelTo:=2)
'get area property data
ret = SapModel.PropArea.GetSlab("MyShellProp1A", SlabType, ShellType, MatProp, Thickness, Color, Notes, GUID)
'get area property data
ret = SapModel.PropArea.GetSlabRibbed("MyShellProp1A", OverallDepth, SlabThickness, StemWidthTop, StemWidthBot, RibSpacing, RibsParallelTo)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub