cPropLink SetMultiLinearElastic Method CSi API ETABS 2015
Initializes a multilinear elastic-type link property. If this function is called for an existing link property, all items for the property are reset to their default values.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int SetMultiLinearElastic(
	string Name,
	ref bool[] DOF,
	ref bool[] Fixed,
	ref bool[] Nonlinear,
	ref double[] Ke,
	ref double[] Ce,
	double DJ2,
	double DJ3,
	string Notes = "",
	string GUID = ""
)

Parameters

Name
Type: OnlineSystem String
The name of an existing or new link property. If this is an existing property, that property is modified; otherwise, a new property is added
DOF
Type:  OnlineSystem Boolean  
Fixed
Type:  OnlineSystem Boolean  
This is a boolean array, dimensioned to 5, indicating if the specified degree of freedom is fixed (restrained).
ValueFixity
Fixed(0)U1 fixity if DOF(0) = True
Fixed(1)U2 fixity if DOF(1) = True
Fixed(2)U3 fixity if DOF(2) = True
Fixed(3)R1 fixity if DOF(3) = True
Fixed(4)R2 fixity if DOF(4) = True
Fixed(5)R3 fixity if DOF(5) = True

The term Fixed(n) applies only when DOF(n) = True.

Nonlinear
Type:  OnlineSystem Boolean  
This is a boolean array, dimensioned to 5, indicating if nonlinear properties exist for a specified degree of freedom.
ValueNonlinear
Nonlinear(0)U1 has nonlinear properties
Nonlinear(1)U2 has nonlinear properties
Nonlinear(2)U3 has nonlinear properties
Nonlinear(3)R1 has nonlinear properties
Nonlinear(4)R2 has nonlinear properties
Nonlinear(5)R3 has nonlinear properties

The term Nonlinear(n) applies only when DOF(n) = True and Fixed(n) = False.

Ke
Type:  OnlineSystem Double  
Ce
Type:  OnlineSystem Double  
DJ2
Type: OnlineSystem Double
DJ3
Type: OnlineSystem Double
Notes (Optional)
Type: OnlineSystem String
GUID (Optional)
Type: OnlineSystem String
The GUID (global unique identifier), if any, assigned to the property. If this item is input as Default, the program assigns a GUID to the property.

Return Value

Returns zero if the property is successfully initialized; otherwise it returns a nonzero value.
Remarks

Examples

See Also