cFrameObj AddByCoord Method CSi API ETABS 2015
Adds a new frame object whose end points are at the specified coordinates.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int AddByCoord(
	double XI,
	double YI,
	double ZI,
	double XJ,
	double YJ,
	double ZJ,
	ref string Name,
	string PropName = "Default",
	string UserName = "",
	string CSys = "Global"
)

Parameters

XI
Type: OnlineSystem Double
The coordinates of the I-End of the added frame object. The coordinates are in the coordinate system defined by the CSys item.
YI
Type: OnlineSystem Double
ZI
Type: OnlineSystem Double
XJ
Type: OnlineSystem Double
YJ
Type: OnlineSystem Double
ZJ
Type: OnlineSystem Double
Name
Type: OnlineSystem String 
This is the name that the program ultimately assigns for the frame object. If no userName is specified, the program assigns a default name to the frame object. If a userName is specified and that name is not used for another frame, cable or tendon object, the userName is assigned to the frame object, otherwise a default name is assigned to the frame object.
PropName (Optional)
Type: OnlineSystem String
This is Default, None, or the name of a defined frame section property.

If it is Default, the program assigns a default section property to the frame object. If it is None, no section property is assigned to the frame object. If it is the name of a defined frame section property, that property is assigned to the frame object.

UserName (Optional)
Type: OnlineSystem String
CSys (Optional)
Type: OnlineSystem String
The name of the coordinate system in which the frame object end point coordinates are defined.

Return Value

Returns zero if the frame object is successfully added, otherwise it returns a nonzero value.
Remarks

Examples

See Also