cPropArea GetDeckUnfilled Method CSi API ETABS 2015
Retrieves property data for an unfilled deck section.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetDeckUnfilled(
	string Name,
	ref double RibDepth,
	ref double RibWidthTop,
	ref double RibWidthBot,
	ref double RibSpacing,
	ref double ShearThickness,
	ref double UnitWeight
)

Parameters

Name
Type: OnlineSystem String
The name of an existing unfilled deck property.
RibDepth
Type: OnlineSystem Double 
Rib Depth, hr
RibWidthTop
Type: OnlineSystem Double 
Rib Width Top, wrt
RibWidthBot
Type: OnlineSystem Double 
Rib Width Bottom, wrb
RibSpacing
Type: OnlineSystem Double 
Rib Spacing, sr
ShearThickness
Type: OnlineSystem Double 
Deck Shear Thickness
UnitWeight
Type: OnlineSystem Double 
Deck Unit Weight

Return Value

The function returns zero if the property data is successfully retrieved; otherwise it returns a nonzero value.
Remarks

Examples

See Also