Sets the frame modifier assignment for frame objects. The default value for all modifiers is one
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int SetModifiers(
string Name,
ref double[] Value,
eItemType ItemType = eItemType.Objects
)
Function SetModifiers ( _
Name As String, _
ByRef Value As Double(), _
Optional ItemType As eItemType = eItemType.Objects _
) As Integer
int SetModifiers(
String^ Name,
array<double>^% Value,
eItemType ItemType = eItemType::Objects
)
Parameters
- Name
- Type:
System String
The name of an existing frame object or group, depending on the
value of the ItemType item.
- Value
- Type:
System Double
This is an array of eight unitless modifiers:
Value | Modifier |
---|
Value(0) | Cross sectional area modifier |
Value(1) | Shear area in local 2 direction modifier |
Value(2) | Shear area in local 3 direction modifier |
Value(3) | Torsional constant modifier |
Value(4) | Moment of inertia about local 2 axis modifier |
Value(5) | Moment of inertia about local 3 axis modifier |
Value(6) | Mass modifier |
Value(7) | Weight modifier |
- ItemType (Optional)
- Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignment is made to the frame object
specified by the Name item.
If this item is Group, the assignment is made to all frame objects
in the group specified by the Name item.
If this item is SelectedObjects, the assignment is made to all
selected frame objects and the Name item is ignored.
Return Value
Returns zero if the modifier assignments are successfully assigned, otherwise it returns a nonzero value
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Value() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ReDim Value(7)
For i = 0 To 7
Value(i) = 1
Next i
Value(5) = 100
ret = SapModel.FrameObj.SetModifiers("3", Value, eItemType.Objects)
Dim myValue As Double()
ret = SapModel.FrameObj.GetModifiers("3", myValue)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Value() As Double
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
'assign modifiers
ReDim Value(7)
For i = 0 To 7
Value(i) = 1
Next i
Value(5) = 100
ret = SapModel.FrameObj.SetModifiers("3", Value, eItemType.Objects)
'get modifiers
Dim myValue As Double()
ret = SapModel.FrameObj.GetModifiers("3", myValue)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub