Makes generated edge constraint assignments to area objects.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int SetEdgeConstraint(
string Name,
bool ConstraintExists,
eItemType ItemType = eItemType.Objects
)
Function SetEdgeConstraint ( _
Name As String, _
ConstraintExists As Boolean, _
Optional ItemType As eItemType = eItemType.Objects _
) As Integer
int SetEdgeConstraint(
String^ Name,
bool ConstraintExists,
eItemType ItemType = eItemType::Objects
)
Parameters
- Name
- Type:
System String
The name of an existing area object or group, depending on the value
of the ItemType item.
- ConstraintExists
- Type:
System Boolean
This item is True if an automatic edge constraint is generated
by the program for the area object in the analysis model.
- ItemType (Optional)
- Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignment is made to the area object
specified by the Name item.
If this item is Group, the assignment is made to all area objects
in the group specified by the Name item.
If this item is SelectedObjects, assignment is made to all selected
area objects, and the Name item is ignored.
Return Value
Returns zero if the edge constraint option is successfully assigned;
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.AreaObj.SetEdgeConstraint("ALL", True, ETABS2013.eItemType.Group)
ret = SapModel.AreaObj.SetEdgeConstraint("2", False)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
'assign auto edge constraint option
ret = SapModel.AreaObj.SetEdgeConstraint("ALL", True, ETABS2013.eItemType.Group)
ret = SapModel.AreaObj.SetEdgeConstraint("2", False)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub