cPropLink GetWeightAndMass Method CSi API ETABS 2015
Assigns weight and mass data to a link property.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetWeightAndMass(
	string Name,
	ref double W,
	ref double M,
	ref double R1,
	ref double R2,
	ref double R3
)

Parameters

Name
Type: OnlineSystem String
The name of an existing link property.
W
Type: OnlineSystem Double 
M
Type: OnlineSystem Double 
R1
Type: OnlineSystem Double 
The rotational inertia of the link about its local 1 axis. [ML2]
R2
Type: OnlineSystem Double 
The rotational inertia of the link about its local 2 axis. [ML2]
R3
Type: OnlineSystem Double 
The rotational inertia of the link about its local 3 axis. [ML2]

Return Value

returns zero if the data is successfully assigned; otherwise it returns a nonzero value.
Remarks

Examples

See Also