cFrameObj GetLoadTemperature Method CSi API ETABS 2015
Retrieves the temperature load assignments to frame objects.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetLoadTemperature(
	string Name,
	ref int NumberItems,
	ref string[] FrameName,
	ref string[] LoadPat,
	ref int[] MyType,
	ref double[] Val,
	ref string[] PatternName,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: OnlineSystem String
The name of an existing frame object or group, depending on the value of the ItemType item.
NumberItems
Type: OnlineSystem Int32 
The total number of temperature loads retrieved for the specified frame objects.
FrameName
Type:  OnlineSystem String  
This is an array that includes the name of the frame object associated with each temperature load.
LoadPat
Type:  OnlineSystem String  
This is an array that includes the name of the load pattern associated with each temperature load.
MyType
Type:  OnlineSystem Int32  
This is an array that includes 1, 2 or 3, indicating the type of temperature load.
  1. Temperature
  2. Temperature gradient along local 2 axis
  3. Temperature gradient along local 3 axis
Val
Type:  OnlineSystem Double  
PatternName
Type:  OnlineSystem String  
This is an array that includes the joint pattern name, if any, used to specify the temperature load.
ItemType (Optional)
Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If this item is Objects, the assignments are retrieved for the frame object specified by the Name item.

If this item is Group, the assignments are retrieved for all frame objects in the group specified by the Name item.

If this item is SelectedObjects, the assignments are retrieved for all selected frame objects and the Name item is ignored.

Return Value

Returns zero if the load assignments are successfully retrieved, otherwise it returns a nonzero value.
Remarks

Examples

See Also