cPropArea GetTypeOAPI Method CSi API ETABS 2015
Retrieves the property type for the specified area property.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetTypeOAPI(
	string Name,
	ref int PropType
)

Parameters

Name
Type: OnlineSystem String
The name of an existing area property.
PropType
Type: OnlineSystem Int32 
This is 1, 2 or 3, indicating the type of area property.
ValueType
1Shell
2Plane
3Asolid

Return Value

Returns zero if the type is successfully retrieved; otherwise it returns nonzero.
Remarks

Plane and Asolid area properties are not supported in ETABS.
Examples

See Also